
Opsætning af SMTP
Formål
Denne artikel beskriver, hvordan du konfigurerer XFlow til at sende e-mails igennem en SMTP-server.
Sidst redigeret: 25/02-2025

Indholdsfortegnelse:
1. Forudsætninger
For at kunne sende mails med XFlow kræver det adgang til en SMTP-server. For SaaS-løsninger er dette allerede konfigureret. Det eneste, du skal gøre, er at oprette en SPF-record for XFlow-SMTP serveren på det domæne, du angiver som afsender af mails.
For lokale løsninger skal der stilles en SMTP-server til rådighed for XFlow.

Du konfigurerer SMTP-serveren i menuen til venstre i adminstrationsdelen under "Systemopsætning > Indstillinger > E-mail". Du kan også vælge at søge efter indstillingen øverst i højre hjørne:
2. Opsætning
Gå efterfølgende til afsnittet "E-mail - SMTP" og udfyld, som minimum, feltet "SmtpServer" med adressen på din SMTP-server:
Du kan yderligere sætte kryds i "SSL/TLS", hvis din SMTP server understøtter dette, samt angive et brugernavn og en adgangskode i felterne "SmtpCredentialUsername" og "SmtpCredentialPassword". Disse felter er valgfrie og dermed kun nødvendige, hvis du ønsker at højne sikkerheden i forbindelse med afsendelse af mails.
Opsætningen er færdig, og du kan nu prøve at gennemføre en arbejdsgang med en e-mail-databehandler for at sikre, at dine indstillinger er korrekte, og at e-mailen bliver modtaget som forventet.

4. Typiske problemstillinger
Problem:
Mails kommer ikke frem.
Årsag:
Én af grundene til, at mails ikke kommer frem, kan skyldes, at afsenderadressen, som er sat i feltet "SmtpReplyAddress", ikke stemmer overens med den SMTP-server, som sender dine mails. Dette er et typisk scenarie for XFlow SaaS, hvis man benytter sig af den tilhørende XFlow SMTP-server.
Løsning:
Du løser problemet ved at tilføje en SPF-record for XFlow-SMTP serveren på afsenderdomænet.
SaaS-kunder kan finde XFlow-SPF recorden i afsnittet ovenfor.