Formål
Denne artikel beskriver, hvordan du konfigurerer XFlow til at sende e-mails igennem en SMTP-server.
Forudsætning
For at kunne sende mails med XFlow kræver det adgang til en SMTP-server.
For SaaS-løsninger er dette allerede konfigureret. Det eneste du skal gøre er at oprette en SPF-record for XFlow-SMTP serveren på det domæne, du angiver som afsender af mails.
For lokale løsninger skal der stilles en SMTP-server til rådighed for XFlow.
Opsætning
Du konfigurerer SMTP-serveren under "System > Indstillinger > E-mail" i menuen i venstre side. Du kan også vælge at søge efter indstillingen øverst i højre hjørne:
Gå efterfølgende til afsnittet "E-mail - SMTP" og udfyld, som minimum, feltet "SmtpServer" med adressen på din SMTP-server:
- Du kan yderligere sætte kryds i "SSL/TLS", hvis din SMTP server understøtter dette, samt angive et brugernavn og en adgangskode i felterne "SmtpCredentialUsername" og "SmtpCredentialPassword".
Disse felter er valgfrie og dermed kun nødvendige, hvis du ønsker at højne sikkerheden i forbindelse med afsendelse af mails. - Opsætningen er færdig, og du kan nu prøve at gennemføre en arbejdsgang med en e-mail-databehandler for at sikre, at dine indstillinger er korrekte, og at e-mailen bliver modtaget som forventet.
SPF ved SaaS løsninger
For at undgå, at dine brugere får problemer med at modtage e-mails, skal du tilføje XFlow SMTP-serveren til SPF-records for det domæne, du benytter som afsender af e-mails i XFlow.
SPF-recorden for XFlow SaaS:
spf.xflow.dk
Typiske problemstillinger
Problem: Mails kommer ikke frem
Årsag:
Èn af grundene til, at mails ikke kommer frem, kan skyldes, at afsender adressen som er sat i feltet "SmtpReplyAddress" ikke stemmer overens med den SMTP-server, som sender dine mails.
Dette er et typisk scenarie for XFlow SaaS, hvis man benytter sig af den tilhørende XFlow SMTP-server.
Løsning:
Du løser problemet ved at tilføje en SPF-record for XFlow-SMTP serveren på afsenderdomænet.
SaaS-kunder kan finde XFlow-SPF recorden i afsnittet ovenfor.